'IMSM'에 해당되는 글 1건

  1. 2009.01.07 965p-ds3 보드(ICH8)에서 AHCI 사용하기
하드웨어2009.01.07 22:29
SATA2 하드의 NCQ 활성화... 그리고 삽질이라는 포스트에서 이어지는(?) 내용이다. 간단히 말하자면, 데이터용으로 새 하드를 하나 사서 붙였는데, 지난번에는 실패한 ICH8 + AHCI 구성을 이번에는 성공했다-_-v

지난번에 왜 실패했는지에 대해선 사실 아직도 원인을 모르겠다. Intel Matrix Storage Manager(이하 IMSM)의 버전(8.1인가 8.2로 기억한다) 때문인지, AHCI 비활성 상태에서 설치한 윈도우(SP2)에서 문제가 생긴 건지, 하드나 보드와의 궁합 문제인지... 나중에 윈도우를 새로 깔 일이 있으면 그때 가서 밝혀지겠지 뭐(가끔 '컴퓨터 느려지면 무조건 포맷해라'라는 식으로 말하는 사람들이 있지만 개인적으로는 이 의견에 반대한다. 내 경우 2년 전에 산 이 컴퓨터를 포맷 한번 안하고 잘 사용중이다. 모든 게 그렇지만, 평소 유지, 보수, 관리하기 나름이다).

어쨌든; 이번에 성공한 방법을 정리해봤다. 하드 설치에 앞선 구성은 다음과 같았다.

바이오스에서 인텔 ICH8 SATA 컨트롤러의 AHCI 모드가 꺼짐(disabled)임을 확인하고 새 하드를 ICH8 SATA 컨트롤러에 연결했다. 다음 스샷 참고. 보드 설명서 pdf에서 가져온 그림이므로 다른 항목은 무시할 것.

bios 화면

bios 화면

이미 2개의 하드를 쓰고 있었는데 파워에 남는 sata 케이블이 없길래 동네에서 2천원 주고 4핀-15핀 젠더 케이블을 사야만 했다. 그리고 윈도우 부팅. 당연히 아무 문제없이 인식이 되는 걸 확인했다. 장치관리자는 다음과 같은 상태.

AHCI 비활성화일 때 장치관리자(연결순)

AHCI 비활성화일 때 장치관리자(연결순)

그리고 문제의 IMSM을 다운받았다. 최신 버전은 8.6.0.1007. 이걸 설치하는 게 목적이 아니라 드라이버만 추출하는 게 목적인데 기존에 알려진 방법과 달리 이번 버전에서는 인스톨러의 압축을 푸는 경로를 지정해도 소용이 없었다. 그냥 파일명 뒤에 -a를 붙여서 실행해주면 기본값인 C:\Program Files\Intel\Intel Matrix Storage Manager에 드라이버 파일들이 풀린다. 이 폴더의 winall\Driver 폴더에 바로 그 iaAHCI.inf 파일이 들어있다.

그래서 위의 스샷에서 새 하드가 연결된 Intel(R) ICH8 4 port Serial ATA Storage Controller - 2820을 우클릭>드라이버 업데이트해서 어쩌고 저쩌고... 디스크 있음에서 iaAHCI.inf를 선택하면 몇 개인가의 목록이 나오는데, 이 목록 역시 기존에 알려진 방법에 뜨는 목록과 많이 다르다. 쫄지 말고 ICH8R로 시작하는 드라이버를 선택해서 설치해봤다. 정확히는 Intel(R) ICH8R/DH/D0 SATA AHCI Controller. 설치는 아무 문제없이 이루어졌고 재부팅하란 말도 없었고 물음표도 뜨지 않았다. 만세-_-)/

이제 재부팅을 할 시간이다. 바이오스에서 SATA를 AHCI로 바꾼 뒤 부팅했다(처음 스샷 참고). 잠시 드라이버 업데이트를 하라는 메시지가 나온다. 위에서 골라준 드라이버와 비슷한(?) 걸 다시 골라주면 된다. 목록이 아까보다 더 여러 개 나오고, ICH8R로 시작하는 게 2개 있었지만 하나는 ICH8R용 AHCI 드라이버고 다른 하나는 ICH8R/ICH9R/ICH10R 어쩌고 RAID 드라이버이므로 AHCI 드라이버를 골라주자. 설치가 제대로 되고, 재부팅은 필요없었다. 그리고 관리 도구에 가보자 새 하드를 인식하고 있었다! 파티셔닝 & 포맷 ㄱㄱ

ICH8 + AHCI 드디어 성공!

ICH8 + AHCI 드디어 성공!

이 시점에서, 기존에 알려진 방법에 써있기도 해서 혹시나 하고 IMSM을 설치하려 했으나 이번에도 설치는 불가능했다. 사실 없어도 그만이니까 패스. 이제 앞자르기를 할지 말지 고민할 시간이다...


덧: 이렇게 설치한 하드는, JMicron 컨트롤러에 물려서 사용중인 기존 하드들과 달리 핫스왑 목록에 뜨지 않았다. 이것이 드라이버의 문제인지, 4핀-15핀 젠더 때문(위키 문서 참고)인지는 분명하지 않다. 물론 내가 핫스왑을 사용할 일은 없으니 별 상관은 없지만.




Posted by 필유